Warp Drive - Throttle Error? - DIY Electric Car Forums
Go Back  

DIY Electric Car Forums > EV Conversions and Builds > Technical Discussion

Register Blogs FAQ Members List Social Groups Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
  #1  
Old 01-10-2017, 06:24 PM
sauron_3746 sauron_3746 is offline
Junior Member
 
Join Date: Feb 2015
Posts: 4
sauron_3746 is on a distinguished road
Default Warp Drive - Throttle Error?

Hi All,

I have a Warp Drive Classic controller with a HETA throttle (it has Toyota written on it and appears to be the prius style throttle). I am having a little issue which is probably simply resolved, I just need to be pointed in the right direction.

It was easier to make a short 2 minute video than try to explain in an email, so if you could please forward to your tech guys it would be much appreciated.

Video here: https://www.youtube.com/watch?v=shZz...ature=youtu.be

Additionally, I have noted that it tends to throw the error when the ignition is set to “on”. I can 'usually' clear the error when the ignition is “off”. I have tried re-routing the throttle cable to avoid interference.

Any assistance will be much appreciated.

Regards

Andrew from Aus..
Reply With Quote
  #2  
Old 01-10-2017, 07:00 PM
dcb dcb is online now
Senior Member
 
Join Date: Dec 2009
Posts: 1,723
dcb is on a distinguished road
Default Re: Warp Drive - Throttle Error?

hopefully netgain gets back to you, could be a contactor issue? (or some other high power connection?), sounds like you have to clear it manually after the problem is fixed.

http://www.ngcontrols.com/datasheets..._31-May-12.pdf

14 Pack went open circuit with system on. This error indicates that somewhere in the pack
there has been an open circuit while the controller
is “started”. This can be the main contactor or a
connection point within the pack.
15 Secondary microcontroller not
responding in required time.
Contact controller manufacturer if the problem persists after clearing the error code

edit: so the LEDs are showing you red then 1 blue then 5 yellow = active code 15. (no red) 1 blue 4 yellow historical code 14 if I'm reading it right.

Last edited by dcb; 01-10-2017 at 07:34 PM.
Reply With Quote
  #3  
Old 01-11-2017, 01:31 AM
sauron_3746 sauron_3746 is offline
Junior Member
 
Join Date: Feb 2015
Posts: 4
sauron_3746 is on a distinguished road
Default Re: Warp Drive - Throttle Error?

Hi DCB,

Thanks for your swift response.

First thing I notice in your reply is that you have a reference for the error codes which leads me down an entirely different path of troubleshooting. And that your error codes are from the newer controllers (Warp Drive 2) user manual. I don't actually own this controller, but the older Warp Drive Classic.

I am receiving two digit DTC codes, which dont correspond to anything in the manual where they are all four digit error codes? Are the newer codes still applicable? Can I trust that these two digit codes are correct when the manual says different?

Is there an easy way I can test your suggested errors?

Regards

Andrew
Reply With Quote
  #4  
Old 01-11-2017, 01:38 AM
dcb dcb is online now
Senior Member
 
Join Date: Dec 2009
Posts: 1,723
dcb is on a distinguished road
Default Re: Warp Drive - Throttle Error?

All I can say is the display and the LED flashing seem to correlate with the document I linked to, really I don't have or retain any model specifics of much of anything, let alone a controller I've never owned

Maybe it got upgraded at some point or you got the wrong manual, or some third option?

edit, maybe a load test of some sort might give a clue, override the contactor, measure various voltage drops (i.e. contactor, then do a "binary search" of sorts on the pack voltages starting at half pack vs pack+ and pack-)

edit: same codes are in other versions of the manual too
http://www.ngcontrols.com/datasheets..._27-Jul-11.pdf

from a page called "warp drive classic" ... http://www.ngcontrols.com/wd1.php

Last edited by dcb; 01-11-2017 at 02:22 AM.
Reply With Quote
  #5  
Old 01-12-2017, 09:37 PM
sauron_3746 sauron_3746 is offline
Junior Member
 
Join Date: Feb 2015
Posts: 4
sauron_3746 is on a distinguished road
Default Re: Warp Drive - Throttle Error?

Hi DCB,

Well it seems you have put me on the right track. First with error 14 and 15, I adjusted and improved some contacts, particularly the negative on the main contactor, that seemed to sort those two errors out. However, I started getting 18, which I now believe was due to heat. I did about 20kms on a warm day (35C) and the IGBT was getting up to 132F, which I believe is pretty close to the limit for it. I recieved a error 18 a couple of times, but was able to clear only be restarting the controller. Drove the car this morning early, IGBT temp only reached 111F, no problem.

I also recieved an error 13 once yesterday, still not sure what that one was about, but did not recieve in the coller conditions today.

More testing to be done.

Andrew
Reply With Quote
  #6  
Old 01-12-2017, 10:10 PM
dcb dcb is online now
Senior Member
 
Join Date: Dec 2009
Posts: 1,723
dcb is on a distinguished road
Default Re: Warp Drive - Throttle Error?

Yay I helped thanks for the ack!
Reply With Quote
Reply

Share or Bookmark this

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

 
Support DIY Electric Car
Sponsors

All times are GMT -6. The time now is 07:10 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Ad Management by RedTyger