Re-using complete Leaf Drive System (w/VCM) - Page 20 - DIY Electric Car Forums
Go Back  

DIY Electric Car Forums > EV Conversions and Builds > Technical Discussion

Register Blogs FAQ Members List Social Groups Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
  #191  
Old 02-16-2017, 01:19 AM
arber333 arber333 is offline
Senior Member
 
Join Date: Dec 2010
Location: Slovenia
Posts: 489
arber333 is on a distinguished road
Default Re: Re-using complete Leaf Drive System (w/VCM)

Quote:
Originally Posted by Cor View Post
Did you also get the high voltage wires?
I have a compressor and wires and hoses from parting out a 2011.
Checked the service manual and saw that the compressor only has 6 wires, the 2-wire control, the 2-wire HV bus, 12V and a connection to the heater pump.
Yes i have a HV wires with connectors and LV wire loom that is still joined with some other wires. LV wires jolin to large multi pin connector. I gather this goes to A/C auto amplifier.

I would like to try the compressor operation on my car battery 380Vdc but i dont know the correct UART sequence for starting and then signal for rpm setting.
When evaporator air is at 0C compressor should stop and when temperature rises to 4C it will start again. It should be simple integrating this with in car A/C relay. I just have to know
1. start command
2. stop command
3. maybe 2 or 3 RPM settings between 50% and 80% of compressor speed

If anyone can record signals from a working LEAF compressor i could then try to interpret and setup my micro controller to clone those signals.

There are still Tx Rx lines, that means inverter wants to put out something. I have to check if this is just reporting or it needs any response to work...

tnx

A
Reply With Quote
Sponsored Links
Advertisement
 
  #192  
Old 02-16-2017, 02:14 AM
arber333 arber333 is offline
Senior Member
 
Join Date: Dec 2010
Location: Slovenia
Posts: 489
arber333 is on a distinguished road
Default Re: Re-using complete Leaf Drive System (w/VCM)

Quote:
Originally Posted by CKidder View Post
That's not a bad idea. Two diode drops would probably be enough to bring the voltage levels down so that both are within the proper target areas. I'll give that a try.
Any luck?
I was thinking, since TTL chips have like 0.8V treshold, couldnt you just connect one to compressor signal connector Vcc across GND with pullup resistor to raise GND reference on chip by 1V7. 5V - 1V7 = 3V3 and then record UART signal trough PC? I think max232 would work from 3V3?

A
Reply With Quote
  #193  
Old 02-27-2017, 03:40 PM
Ruudi Ruudi is offline
Junior Member
 
Join Date: Dec 2009
Location: EU, Estonia
Posts: 10
Ruudi is on a distinguished road
Default Re: Re-using complete Leaf Drive System (w/VCM)

Is it possible to run Leaf motor with original systems from lower voltage battery? Leaf has 96S pack. Would it run with 88S Li battery pack? Would it run without BMS? If it will not how to make it think that everything is fine?
Reply With Quote
 
  #194  
Old 03-11-2017, 08:44 PM
MrZion MrZion is offline
Junior Member
 
Join Date: May 2016
Posts: 21
MrZion is on a distinguished road
Default Re: Re-using complete Leaf Drive System (w/VCM)

miscrms, I would really like to talk about the feasibility of doing this type of conversion, please send me a PM.

Cheers
Reply With Quote
  #195  
Old 04-20-2017, 01:08 PM
zepol_wube zepol_wube is offline
Junior Member
 
Join Date: Oct 2015
Location: East Central Illinois
Posts: 8
zepol_wube is on a distinguished road
Default Re: Re-using complete Leaf Drive System (w/VCM)

Ruudi, look at what Wolftronix.com is doing with breaking up LEAF packs and reprogramming the BMS.
__________________
--
Pezz

Lopified.blogspot.com
Reply With Quote
  #196  
Old 04-20-2017, 03:25 PM
Cor Cor is offline
Junior Member
 
Join Date: Sep 2013
Posts: 24
Cor is on a distinguished road
Default Re: Re-using complete Leaf Drive System (w/VCM)

Quote:
Originally Posted by Ruudi View Post
Is it possible to run Leaf motor with original systems from lower voltage battery? Leaf has 96S pack. Would it run with 88S Li battery pack? Would it run without BMS? If it will not how to make it think that everything is fine?
Define "Leaf Motor".
The motor will run fine on any AC controller programmed for approx this motor and voltage, there is not much difference between 88s (350V) and 96s (380V)
If you want to re-use the full Leaf drivetrain and inverter to drive the motor and want it to work on 88s pack, that is a bit trickier, you will need to trick the BMS into thinking that it still has the full 96s pack, which is not too difficult but requires a bit of electronics and wiring.
In theory, a simple switching power supply for an ink jet printer or other small AC-DC supply that can work on any voltage between 100-240V and delivers 32V or more is what is needed, plus a series of resistor voltage dividers. Let me know if you need more info.
Cor.
Reply With Quote
Reply

Share or Bookmark this

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

 
Support DIY Electric Car
Sponsors

All times are GMT -6. The time now is 11:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Ad Management by RedTyger