DIY Electric Car Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
Hello all,

I am looking for some global wisdom from folks who own, maintain and still drive their Azure Dynamics Transit Connect mini vans.

Since purchasing our Azure Transit Connect a little over a year ago for my local service business, I have had the luck to drop the battery pack to manually top balance one half of the pack (ESS1) after the Panasonic AEV14012 main contactors welded themselves shut after returning back to our shop after a service call. All four main contactors have been replaced. The 12VDC battery was also recently replaced when the Azure diagnostic software revealed the 12VDC bus was occasionally dipping to 10VDC which triggered three DTC codes whenever the van was shifted into reverse. Worked fine in drive. It now reveres normally and the low voltage bus voltage sits at 12.6VDC when off and 14.6VDC when the vehicle is at idle or running.

But...I am convinced that there is something else going here (other than being an orphaned AZD) which is causing the van to draw excessive current when accelerating. Pulling onto a freeway onramp will easily draw 130-140A from pack which exceeds the contactors 120A rating. Forget about flooring it - I think that might weld them again.

I had the opportunity to test drive another AZD Transit three years ago and I remember the van feeling more spirited and not so whiney. It was a 2012 verses my 2011.

So what has been your experience with your Transit Connect? Does your AZD transit Connect sound like mine does in the video? I know these vehicles are orphaned along time ago but trying to get the most of what I have and perhaps help others in the process.

The software on both BMS modules, DMOC, and VCU have been flashed to the MY 2012 versions.

Thanks for your input.

Eric

 

·
Registered
Joined
·
15 Posts
Reply: I have a Ford Transit Connect 2011 Azure Dynamics and I am not sure I notice anything unusual in the sounds in your video.

Hello all,

I am looking for some global wisdom from folks who own, maintain and still drive their Azure Dynamics Transit Connect mini vans.

Since purchasing our Azure Transit Connect a little over a year ago for my local service business, I have had the luck to drop the battery pack to manually top balance one half of the pack (ESS1) after the Panasonic AEV14012 main contactors welded themselves shut after returning back to our shop after a service call. All four main contactors have been replaced. The 12VDC battery was also recently replaced when the Azure diagnostic software revealed the 12VDC bus was occasionally dipping to 10VDC which triggered three DTC codes whenever the van was shifted into reverse. Worked fine in drive. It now reveres normally and the low voltage bus voltage sits at 12.6VDC when off and 14.6VDC when the vehicle is at idle or running.

But...I am convinced that there is something else going here (other than being an orphaned AZD) which is causing the van to draw excessive current when accelerating. Pulling onto a freeway onramp will easily draw 130-140A from pack which exceeds the contactors 120A rating. Forget about flooring it - I think that might weld them again.

I had the opportunity to test drive another AZD Transit three years ago and I remember the van feeling more spirited and not so whiney. It was a 2012 verses my 2011.

So what has been your experience with your Transit Connect? Does your AZD transit Connect sound like mine does in the video? I know these vehicles are orphaned along time ago but trying to get the most of what I have and perhaps help others in the process.

The software on both BMS modules, DMOC, and VCU have been flashed to the MY 2012 versions.

Thanks for your input.

Eric

 
1 - 2 of 2 Posts
Top