DIY Electric Car Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
18 Posts
Recommended replacement time of the oil in the user manual is after 100,000 miles or 160,000 km , so far I don't know of any AZD vans that have got near to that. It is a special very low viscosity oil and I might have its spec somewhere if you need it. If the vans have been heavily loaded and then the max torque has been used for acceleration then I've heard about problems , but in most vans they have not been the main source of problems.
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #5 ·
Recommended replacement time of the oil in the user manual is after 100,000 miles or 160,000 km , so far I don't know of any AZD vans that have got near to that. It is a special very low viscosity oil and I might have its spec somewhere if you need it. If the vans have been heavily loaded and then the max torque has been used for acceleration then I've heard about problems , but in most vans they have not been the main source of problems.
Well, no where near that...im at 23,000 miles and although I do push the power in traffic once in a while, never fully loaded, I love my AZURE wishes it charged faster...thanx for your help
 

·
Registered
Joined
·
18 Posts
Yes charging at 3kW is no fun on this quite large battery pack. Since it uses one of the excellent Brusa battery chargers then there should be a route to parallel two Brusas up, as early Nissan Leaf owners did. But to be honest I have other more fundamental fault finding to do on them at the moment with sensor circuits failing in the battery pack so no time to consider this. And to be honest I've just adjusted my usage to its range and use it accordingly. I look after a couple of these vans. Mine has a range of about 60m, but another one I look after is up towards 80m - it had much less use so far.
 

·
Registered
Joined
·
63 Posts
Hi guys, two years ago I bought the same FORD, a very good car for me. Everything was fine except for some transmission noise. We opened the gearbox, one bearing was broken and the gearbox was completely dry! We changed the bearing and added oil (very easily, without any problem).Now I have the problem with HV battery: one side want work (the same problem as: 2012 Azure Transit Connect P0B3F-F1 Hybrid Battery..., one to one). One of the BMS board is not sending tension value. So, is it possible to find out such kind of boards anywhere as a spare parts of Ford Connect?
BR
 

Attachments

1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top