DIY Electric Car Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
4 Posts
Hi,


Wonder if the two of you might be able to help. My project is up and running (just) and I am slowly getting the bugs ironed out - like an Orion 2 with US Firmware not European and the J1772 got confused! It goes and runs well, but for the life of me I can't get the regen to work. (perhaps I should say - the way I want it to work)



The System is a Curtis 1238 - 7501, AC31, 4 Tesla modules, Orion 2 BMS, and a TCC/Alcon charger.



I dont find the Curtis manual very clear and I suspect that their words mean different things to me than they actually intend! They appear to have Throttle Brake , EM Brake Control, and 'Interlock' brake control. As well as Emergency Reverse!



I dont want to use the over-run throttle regen, I want and have set the throttle with a 'coast mode', so that at zero throttle I have no positive or negative motor torque. I have the position holding all off. I then want to use a processed variable voltage on the Brake Pot input to control the regen.



The only way to get regen appears to be if I use an 'offset' on the throttle - effectively giving me a negative throttle input. I dont want to be 'floating the throttle' to give me coast.



I have the controller set up with both Throttle and Brake pots (I am using 0 to 5 V inputs, and the throttle works fine, the Brake pot is giving the correct raw and input signals in the 'Monitor' function of my 1313). Externally, I have set the Interlock to only drop out if I drop either of the active Forward and Reverse inputs.



Is the correct method to drop the Interloc input to 'open' with the car in either forward or reverse, and will the Brake pot input then be able to control regen braking?


Sorry, I am probably being stupid. :(
 

·
Registered
Joined
·
4 Posts
Hi,


Wonder if the two of you might be able to help. My project is up and running (just) and I am slowly getting the bugs ironed out - like an Orion 2 with US Firmware not European and the J1772 got confused! It goes and runs well, but for the life of me I can't get the regen to work. (perhaps I should say - the way I want it to work)



The System is a Curtis 1238 - 7501, AC31, 4 Tesla modules, Orion 2 BMS, and a TCC/Alcon charger.



I dont find the Curtis manual very clear and I suspect that their words mean different things to me than they actually intend! They appear to have Throttle Brake , EM Brake Control, and 'Interlock' brake control. As well as Emergency Reverse!



I dont want to use the over-run throttle regen, I want and have set the throttle with a 'coast mode', so that at zero throttle I have no positive or negative motor torque. I have the position holding all off. I then want to use a processed variable voltage on the Brake Pot input to control the regen.



The only way to get regen appears to be if I use an 'offset' on the throttle - effectively giving me a negative throttle input. I dont want to be 'floating the throttle' to give me coast.



I have the controller set up with both Throttle and Brake pots (I am using 0 to 5 V inputs, and the throttle works fine, the Brake pot is giving the correct raw and input signals in the 'Monitor' function of my 1313). Externally, I have set the Interlock to only drop out if I drop either of the active Forward and Reverse inputs.



Is the correct method to drop the Interloc input to 'open' with the car in either forward or reverse, and will the Brake pot input then be able to control regen braking?


Sorry, I am probably being stupid. :(
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top