DIY Electric Car Forums banner
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi
Can anyone give me some advice regarding the following Curtis Controller problem:
I have built an electric special on a 1937 chassis. I removed the motor and controller from an existing donor vehicle (a Citroen C1 Cevie).
The motor is the AC31 and the controller a Curtis 1238 650. Originally it ran on 25 Thundersky LiFepo4 cell pack - although, believing I’m still within the limits, I have fitted 28 100aH Winston LiFepo4 cells, all of which have been balanced up to 3.65v.
I have removed everything that a modern vehicle would need - this is classed by DVLA as an Historic Vehicle on its original chassis (with V5c documents etc); what bits of 12v system I require have been isolated on a separate circuit, except for the supply to the 12v relay to switch on the main traction pack voltage.
Basically I just want to go forwards (and backwards!) Anything else will be a bonus.

I have a hand-held programmer but am ignorant re; the electronic side of things.
I am presuming the programmer is reading the settings as previously registered in the Cevie, so the only difference now should be the battery/cell/voltage figures.
On activating the contactor I am getting a flashing amber light on the controller (which I believe is a good thing), but no movement when the throttle is pressed.
The programmer is giving me 2 separate diagnostic exclamation marks:

1) Parameters>Current limits >Drive current limit 0%
When I try to set this to within range (which it says is 5% - 100%) the programmer resets to 5% and then just counts down to zero again, so presumably there is something that the controller doesn’t like in its parameters that makes it stop.

2) Parameters>battery> Undervoltage cutback Range is set at 24.5v so I reset it to within range (max.14v)

I’ve set the Nominal voltage setting to 84v (and have tried it at 90v)

Has anyone got any ideas as to why the Drive Current setting is not agreeable to the controller? Is there a chart showing preferred parameters if I input my own voltage values etc?

Hope someone can give me a few tips on what to try next!

Jon
120537
120538
 
1 - 1 of 1 Posts
Top