DIY Electric Car Forums banner

DMOC 445 Contactor Not Closing

2483 Views 5 Replies 3 Participants Last post by  rclugnut
I know this is covered in other threads, but not to the level that it helps me with my problem. I've been having this issue for several months now and I'm just not smart enough to figure it out on my own...

Here's the backstory:
I bought a brand new DMOC 445 and AC24LS directly from Azure just a few months before they went under (when Azure and Electro Auto had the discount). I have the high-voltage setup; 100GBS batts in series (currently showing as 340V at the HV terminals). I ran the motor several times with no issues.
Then it just quit working. No contactor click, no ccShell interface. I sent it to Gary Snyder and it worked fine for him. He sent it back to me and it worked again for a couple of months (maybe used 4 or 5 times).

Now it's just the SOS. No contactor click, no interface.
Last weekend, I tried rigging up a new 35-pin connector with just the basic connections as detailed in the Troubleshooting portion of the DMOC guide, but even that didn't work.

Any thoughts or suggestions would be greatly appreciated!

1 - 1 of 6 Posts
Pin 20/29 shouldn't be connected from what i can tell. I'm attaching a few manuals i've collected... It's been a while since i've worked with this system so it's hard to say.


1 - 1 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.