DIY Electric Car Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
I cant get my BMS Cell Group Modules to see one set of batteries. The Discover devises page sees the CGM's but the CGM on the front battery pack does not see any cell monitors. (I have 12 cells in the front of the vehicle and 36 cells in the rear of the vehicle). The rear set works perfectly on one CGM.
Does anyone have experience with the EMUS BMS system?
The system worked when I built it and drove it for 6 months, I then upgraded the firmware on the Control module and the cell communication failed. Been trying to solve this for over 6 months with no progress. Cant charge the batteries until I can get the CGM to see the cell monitors.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #3 ·
I tried going back to the original firmware but it still did not work.
I have purchased a new controller. NO joy.
The Lap top control program sees the CGM's with serial numbers when discovering devices on the CAN bus but the CGM monitoring the front battery pack of 12 cells does not see any Cell monitors.
I tried moving the CGM on the CAN bus to the front of the car to eliminate the long serial bus wire and it still does not see the cell monitors. The rear pack of batteries is 36 cells and I put all of them on one CGM in the rear of the vehicle and it sees all 36 cells with no problem. Just cannot get the CGM to see the 12 cells in the front of the vehicle.

Any ideas would be greatly appreciated.
 
1 - 3 of 3 Posts
Top