DIY Electric Car Forums banner

FS: Mitsubushi Cabin Heaters for AZD Transit

2138 Views 12 Replies 8 Participants Last post by  malinaolivers
I have for sale a small number of Mitsubishi cka411a001 Cabin Heaters. Brand new, in opened packaging. Been sat in storage for a few years.

These are most commonly used in the Azure Dynamics Ford Transit Connect. I understand a number of these vehicles were sold missing the heater units.
These units are perfect for adding a cabin heater into your EV.

Any interest please let me know. I can pass on full details and photographs. Based in UK. But can possibly ship.
1 - 13 of 13 Posts

· Registered
Azure Dynamics (Ford) Transit Connect 2012
Joined
·
36 Posts
I have for sale a small number of Mitsubishi cka411a001 Cabin Heaters. Brand new, in opened packaging. Been sat in storage for a few years.

These are most commonly used in the Azure Dynamics Ford Transit Connect. I understand a number of these vehicles were sold missing the heater units.
These units are perfect for adding a cabin heater into your EV.

Any interest please let me know. I can pass on full details and photographs. Based in UK. But can possibly ship.
Hi!

Do you have any of these left??
 

· Registered
Joined
·
5 Posts
Hi to all ! I do also need a heater, please. I removed the cover and it looks like something has burnt out. Don´t know if it can be repaired, so i look for replacement. Can i run the car without this heater - how ? Thank a lot for Your replies !
 

· Registered
Joined
·
17 Posts
It's a pretty common failure on AZD vans. And it often prevent your battery from precharging correctly.

The heater fuse quite hard to access (under the vehicle belly pan, un the HV junction box. Schematic is inside the box itself)

If you are HV-savvy there is also the possibility to disconnect the HV connector going to this heater, right there under the hood. You'll be left with an open HVIL contact, that you need to address. And an exposed open HV connector, that you also need to deal with and protect from weather, water, and fingers!
 

· Registered
Joined
·
5 Posts
Thanks for that hint !
My TCe is still not running/charging.
I have about 350V DC
Blinking turtle, wrench light and red attention sign lights up
When i turn ignition on relays in battery switch on and off
Any other hints or tips ?
 

· Registered
Joined
·
17 Posts
The heater "leaking" HV POS to HV NEG while the battery is trying to do its pre-charge and close its contactors is the FIRST thing to check. That will eliminate a major chunk in your mystery.

The next weak thing to check (that can also leak and prevent your pre-charge, with similar symptoms), is the Active Discharger device, black box plastic thing located in the HV junction box under the vehicle. It is used by the system to discharge the few capacitors on HV bus (mainly in the DMOC drive, chargers, DCDC, etc) once you turn off the vehicle. If this device is fried or defective, it will also prevent a proper pre-charge and prevent contactors from closing. Your vehicle can live without the Active Discharge device if you can live with a permanent check-engine-light. (then if you are ready to fork out money, you can try to find a remplacement).

So first: disconnect that heater (or better : heater fuse).
And second: disconnect that Active Discharger.
 
1 - 13 of 13 Posts
Top