DIY Electric Car Forums banner
1 - 1 of 1 Posts

· Registered
2 Posts
Discussion Starter · #1 ·
Hi everyone,

I am wondering if anyone would be able to advise as to what I can try to fix the issues Im facing trying to get can data transmitting on my GEVCU. I am currently not seeing any can bus traffic coming from the GEVCU and it is not registering any can messages either.

I am running the GEVCU rev 6.2c with a DMOC 645 and Siemens motor ( with a pot accelerator and a pot brake, ( pre charge relay and main relay work fine)) . I have programmed the DMOC and am seeing the following faults from cshell:


I have tried uploading the latest version from the Collins GEVCU6 repo to my GEVCU as well as the binary I found on EVTV but I am still not seeing any CAN traffic. I also connected a CANable pro (CAN <->USB adapter) and using cangaroo (GitHub - HubertD/cangaroo: open source can bus analyzer software) I can see the DMOC CAN traffic, but not the GEVCU traffic. I also tried to scope the GEVCU can HI/LO when not connected to other devices but didn't see any results. I tried this with both Can1 and Can0 with similar (lack of ) results.

Product Rectangle Font Screenshot Parallel

I looked into the code a bit and it looks like in due_can the frames are getting queued in sendFrame: due_can/due_can.cpp at master · collin80/due_can but never dequeued. I am not seeing the software calling mailbox_int_handler(uint8_t mb, uint32_t ul_status) (due_can/due_can.cpp at master · collin80/due_can) so im not sure if the interrupt handler gets initialized properly. I can see that the interrupt handler should get initialized in due_can/due_can.cpp at master · collin80/due_can but Im not sure if its getting called. I tried to see if it goes into the if statement but the Arduino serial monitor start is a bit delayed after the initialization of the hardware so i can never see the first few iterations of the looping. What im seeing is that the sendFrame never gets past "if ( isRingBufferEmpty(txRing)", is there a way to clear the ringBuffer manually( or is that a bad idea)?

Does this sound like a software issue or potentially the can bus chips being burned out? Any thoughts or ideas as to what to test next would be really appreciated.

Thank you
1 - 1 of 1 Posts