DIY Electric Car Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Help

I took this video to ask for help from the EV boards, and others who may know. I am using a Kelly KD series SepEx motor controller. The battery back is 6-12v batteries (lead acid), so a 72v nominal system. The problem is it has no power. The wheels did run fwd and rev but no power to move the kart. Up on blocks the wheel spin like crazy and seem like theres no stopping them. When I get excited and put the kart down theres nothing there. In fact I can hold the wheel in place with a bear hug while my wife presses the accelerator. Whats the issue. Is the controller really that bad? Would a better controller totally fix this problem?

I was considering investing in a better contoller but the last thing I want to do is spend the money and have the same results. I am not totally ignorant about motora and electronics but I am not an expert either. Is my motor ok, can an improper field setting take an otherwise large motor and make it crap? Any imput is appreciated. I am really tryin gto learn an put my finger on the problem. I dont believe its my motor, and I am pretty sure I have enough avail power. The weakest point I think is that damm kelly controller.

I have more stories about the kelly contoller but Ill save that for another time.
Thanks

http://www.youtube.com/watch?v=3h1GQBugn-8
 

·
Registered
Joined
·
7,837 Posts
Help

I took this video to ask for help from the EV boards, and others who may know. I am using a Kelly KD series SepEx motor controller. The battery back is 6-12v batteries (lead acid), so a 72v nominal system. The problem is it has no power. The wheels did run fwd and rev but no power to move the kart. Up on blocks the wheel spin like crazy and seem like theres no stopping them. When I get excited and put the kart down theres nothing there. In fact I can hold the wheel in place with a bear hug while my wife presses the accelerator. Whats the issue. Is the controller really that bad? Would a better controller totally fix this problem?

I was considering investing in a better contoller but the last thing I want to do is spend the money and have the same results. I am not totally ignorant about motora and electronics but I am not an expert either. Is my motor ok, can an improper field setting take an otherwise large motor and make it crap? Any imput is appreciated. I am really tryin gto learn an put my finger on the problem. I dont believe its my motor, and I am pretty sure I have enough avail power. The weakest point I think is that damm kelly controller.

I have more stories about the kelly contoller but Ill save that for another time.
Thanks

http://www.youtube.com/watch?v=3h1GQBugn-8
Hi ames,

Answer a few questions please.

1) Looks like those are 6 volt batteries. Please confirm. You say a 72V system. Let's see a voltmeter reading on the battery set.

2) Motor nameplate is 36 volt. Why are you using a 36V motor with a 72V system.

3) You say it is a SepEx. How do you know the motor is a SepEx wound motor?

4) What is the specification of the controller?

5) I cannot see due to the chain guard, but it appears to be an overdrive. All carts, bikes and other such EVs have a much larger sprocket on the wheel than on the motor shaft. To the tune of 4 to 1. If you in fact have a larger sprocket on the motor than the wheel, it would explain the very low wheel torque. Remove the chain guard and let's see what you have.

6) How were the parameters set for the controller to match the motor characteristics?

7) Please show a complete wiring diagram.

Even with the heavy cart, that size motor is capable of moving it around pretty well, with the proper drive ratio.

I can't tell you if that controller is toasted or not. But might be able to see some other issues with more info.

Regards,

major
 

·
Registered
Joined
·
22 Posts
Discussion Starter #3
1) Looks like those are 6 volt batteries. Please confirm. You say a 72V system. Let's see a voltmeter reading on the battery set.

The batteries are 12v and the pack is fully charged. Aprox 88-89 volts off the pack.


2) Motor nameplate is 36 volt. Why are you using a 36V motor with a 72V system.

Because I wanted tire smoking torque. The windings in the motor are thick so I figured I would over volt it for even more power.


3) You say it is a SepEx. How do you know the motor is a SepEx wound motor?

By taking the motor apart and looking at the windings. In addition to its 4 posts A1, A2, F1, F2


4) What is the specification of the controller?

It is a SepEx. Page 11 of this document is the wiring diagram. http://www.kellycontroller.com/mot/downloads/KellyKDUserManual.pdf


5) I cannot see due to the chain guard, but it appears to be an overdrive. All carts, bikes and other such EVs have a much larger sprocket on the wheel than on the motor shaft. To the tune of 4 to 1. If you in fact have a larger sprocket on the motor than the wheel, it would explain the very low wheel torque. Remove the chain guard and let's see what you have.

I purposly ran a ratio of close to 1:1. Its about 1: 1.2 so yes I know I will need a lot of torque but I figues with the size of th emotor and the 72v pack I would have enough.


6) How were the parameters set for the controller to match the motor characteristics?

I dont know, maybe this is my weakness.

7) Please show a complete wiring diagram.

Page 11 here http://www.kellycontroller.com/mot/downloads/KellyKDUserManual.pdf
 

·
Registered
Joined
·
7,837 Posts
2) Motor nameplate is 36 volt. Why are you using a 36V motor with a 72V system?

Because I wanted tire smoking torque. The windings in the motor are thick so I figured I would over volt it for even more power.
Start with the lowest voltage for the controller specification, or in this case 36V. Get it running and work your way up, keeping an eye on motor RPM.
3) You say it is a SepEx. How do you know the motor is a SepEx wound motor?

By taking the motor apart and looking at the windings. In addition to its 4 posts A1, A2, F1, F2
F1 and F2 probably indicate it is a SepEx. What is the resistance of the field (between F1 and F2 with the controller disconnected)?

4) What is the specification of the controller?

It is a SepEx. Page 11 of this document is the wiring diagram. http://www.kellycontroller.com/mot/downloads/KellyKDUserManual.pdf
Is it a model rated for 72V?

5) I cannot see due to the chain guard, but it appears to be an overdrive. All carts, bikes and other such EVs have a much larger sprocket on the wheel than on the motor shaft. To the tune of 4 to 1. If you in fact have a larger sprocket on the motor than the wheel, it would explain the very low wheel torque. Remove the chain guard and let's see what you have.

I purposly ran a ratio of close to 1:1. Its about 1: 1.2 so yes I know I will need a lot of torque but I figues with the size of th emotor and the 72v pack I would have enough.
This is bad thinking on your part. A higher than normal voltage to the motor will not increase its torque. It will increase its RPM. In which case you need an ever greater reduction ratio. Go back to 36V and put in at least a 4 to 1 ratio. Then when you increase voltage later and get higher RPM, increase the ratio to like 6 to 1. Looking at your set up, this may require a jackshaft and double reduction, or lenthtening of the frame.


6) How were the parameters set for the controller to match the motor characteristics?

I dont know, maybe this is my weakness.
Maybe???? With these SepEx systems, you need to set up the controller to match the characteristics of the particular motor which you have connected to it. This includes a field map and parameters such as field resistance, inductance and maximum and minimum field current. Not having done this is likely the reason of the poor performance.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #5
Thanks Major.

I am thinking I overestimated the power of the motor. I may have to reduce that gearing. I can do that by mounting my axel on the bottom instead of the top. I had this in mind from the start.

I also think I need to learn more about the feild characteristics. I cant measure the resistance because I dont have a mili ohm meter. The resistance is dam near zero which it should be. What the reactance is, I dont know, and i dont know the current rating of the field. Live and learn.
 

·
Registered
Joined
·
7,837 Posts
I cant measure the resistance because I dont have a mili ohm meter. The resistance is dam near zero which it should be.
On a SepEx motor, the field will likely be around 1 ohm. Maybe a fraction, but measurable with a good multimeter. Just zero the meter first, or if it is digital, read the meter with the probes shorted and then subtract that "zero" figure from your measured value. The series motors have the field resistance in the milliohm range and cannot be measured with the normal multimeter.

major
 

·
Registered
Joined
·
22 Posts
Discussion Starter #7 (Edited)
I just measured it. its 1.1 ohms and that included about 24" of #8 copper lead. It may be exactly one with out the wires comming off the motor. I was too lazy to access the motor to detach one so I measured at the controller with one taken off. I have this wavetek meter and it has a calibration cert (out of date) so its pretty accurate. I think I am going to go ahead and change my gearing to a 6:1

 

·
Registered
Joined
·
22 Posts
Discussion Starter #8
Hey Major,


I looks at my gearing and my current setup I have a 17 tooth sprocket driving a 20 tooth, so almost one but not quite, a ratio of .850.

The smallest drive sprocket I can get is an 11 tooth, and the largest driven sprocket I can fit/ get is a 40 tooth. I am going to make this switch which will give me a ration of .275

You recomended a 1/6 or a .167.

Ill try this an get a new controlelr. If this does not work I am screwed.

Thanks.
 

·
Registered
Joined
·
66 Posts
I would say if the controller will not allow you to program it then there's the problem.

Try running 1/2 your pack 36 volts and get it running and slowly ramp it up.

Charlie
 

·
Registered
Joined
·
44 Posts
Hey, I just emailed Kelly Controlls about a similar Series system Im building, They informed me the KD series will error if its given more than 88 volts
 

·
Registered
Joined
·
1,627 Posts
Hey, I just emailed Kelly Controlls about a similar Series system Im building, They informed me the KD series will error if its given more than 88 volts
Many thanks!!
It's nice to know the exact number. Well, the KD series will be just perfect for a cheap conversion of 26 LifePO4 cells (3.35v after end of charge).

For information, my Kelly KDHD 144v indicate fault at 180.8v.
 
1 - 11 of 11 Posts
Top