DIY Electric Car Forums banner
1 - 9 of 9 Posts

· Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
Hi,

I have a VW campervan converted to electric. 144V traction battery pack connected to the usual 12V aux, converted by someone else but I know how most of it works.

Since the weekend, the aux battery hasn't been charging. Normally a relay would connect the circuit when the ignition was turned and you would hear the brake servo tone change. Now The aux battery runs flat and the vehicle stops with a full charge on the traction pack. I know the aux battery is fine as I replaced it with a new one and I get the same issue.

I suppose I'm asking what do I check first? How do I know the DC-DC converter is working?

Any help would be appreciated.

Thanks
 

· Registered
Joined
·
2,162 Posts
When I turn the ignition the voltage of the aux drops. How do I know if this s id a faulty dc-dc converted, or a faulty relay, or something else?
technically then your DC-DC is NOT working. You have to troubleshoot it...

Start by measuring the voltage going into the DC-DC converter, and the voltage coming out (right at the converter), with system off and on. If the input is right and the output is still sagging, then it is a problem with the converter. Look for a fuse or something on the converter.

If the input voltage is off (0, or even noticably less than battery voltage) then look upstream of the converter.

if the output voltage is good (i.e. 13+volts or so) then look downstream.
 

· Registered
Joined
·
15 Posts
Discussion Starter · #6 ·
Thanks for all your help.

The issue was upstream. A Littelfuse 6A time delay fuse had blown. Ordered another but they only stock 'quick blow' fuses of that variety. I don't think anything in this circuit should have a high inrush current so that should be fine. What do you think?
 

· Registered
Joined
·
1,033 Posts
You might want to make an effort to determine WHY the fuse blew. It might simply be a little too small, though a 6A slow-blow seems about right for a 144-12v converter assuming it is rated at about 400-500 watts.

be careful about using automotive rated breakers on the input side. they are not rated for the voltage. However you can often find surplus specialty electronics like breakers, fuses, etc with DC ratings on ebay among other places.

I've taken to installing EMI / Line filters on the input side of my DC/DC converters. you can get these quite cheap on ebay, and even in a DC circuit they will help protect your DC/DC and other smaller high voltage loads from transient noise caused during charging and when the controller is operating.

Good luck.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top