DIY Electric Car Forums banner

HowTo Tesla - Repairing the Black MCU Screen/ Constant Rebooting

3198 Views 3 Replies 3 Participants Last post by  GLT
1 - 4 of 4 Posts
Excellent... glad to see you back. My thanks to your earlier posts (which I had to dig a bit to find), which helped me greatly in the process. I hope I can help contribute as well.

A quick note: I found that the SD-card based AllSocket adapter referenced above had trouble reading my particular Hynix chip (a H25M42001FMRI).

Engineering at AllSocket confirmed it was incompatible (likely due to that model chip needing a different value filtering cap).

I purchased this instead, and it worked like a charm:


It also has some other features such as:

- Write protect switch
- Power and activity/status LED's
- Power switch (handy for re-detecting hardware for troublesome recovery)

It also doesn't require buying a quality USB-to-SD adapter if your computer doesn't already have one, helping offset the additional cost.
See less See more
Nice, thanks scaesare. It is a bit spendy tho.

Don't understand why the MMC-based one wouldn't work on yours. Works fine for me. (Feb 2015 build P85D)
I think it may be the vintage of eMMC. The datasheet for the early Hynix chips specifies a 1pf capacitor decoupling VDDi. The value of cap C2 on the SD adapter is only 0.1pf:

Somebody who swapped out that cap said they were able to get it to operate successfully.
See less See more

Thanks for reposting, I am sure it will help many!

I had been preparing for this operation for a long time, but then had to perform it urgently in the end of Nov, and then had to redo much of the research from scratch. (Including finding the ethernet pinout error in the Tesla schematics that I see corrected in the image above :) )

Some of my experiences for the benefit of others:
The amount of bit-errors in the already failing eMMC increased massively after de-soldering (probably due to the heat exposure), but otherwise it read fine in the AllSocket.

Fortunately I had managed to read some images using fly-leads and an ISP, so doing that is advisable!
Sadly it was very hard to get an in-circuit readout to work using either the AllSocket adapter, or a 1-bit capable SD card reader (Transcend RDF5) with custom adapters. In the end we had to cut D0 to the CPU (transmission line reflections are a bitch), short out all crystals on the Tegra board (to halt the CPUs), and run the board at full 3.3V voltage to make it work...

I used a 16GB Swissbit EM-26, preconfigured for extended reliability (Effectively halving the usable size). That worked fine in the CID. (But be careful if doing this to the CI, as that allegedly has an older kernel that might not support eMMC 5.0). If using a low level programmer, burn also the (writable bits in the) EXT_CSD area, as copied from the original chip.

I wrote some custom tools to merge together a working image from the bits and pieces recovered, but otherwise unsquashfs, diff -r, and fsck are your friends, and should hopefully be enough...

See less See more
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.