DIY Electric Car Forums banner

Upgrade to Leaf motor and OpenInverter, or stick with brushed DC MTC-4001?

  • Leaf motor + OpenInverter

    Votes: 0 0.0%
  • MTC-4001

    Votes: 0 0.0%
1 - 2 of 2 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hi all! I'm an engineer by day doing mostly PCB design, and at night I tinker with random electronics and EVs. In college I did FSAE, as a kid I did electric RC planes. Now I have a ~35HP electric kart (16s Leaf cells + ME0709 + 500A motor controller, very fun and a bit terrifying) and also one of the earliest "modern" EV conversions around!

I've recently obtained an MG Midget that was originally converted to electric in 1992. Some of you are probably familiar with this project; it was converted by David Coale, Otmar Ebenhoech, Bob Schneevies, Mike Aaron, Jeb Eddy, Paul Hebert, David Smernoff, and possibly others. This was all done in the Palo Alto area.

First off, here's a quick drive in the car last week:

And here's the original "manual" from the conversion: BAA, EV Project, Manual for the Electric MG Midget

Originally the conversion was done with a MTC-4001 series-wound DC motor, a 600A motor controller, and a bunch of lead-acid batteries for around a 25 mile range.

Based on log books, it was converted with ~75k miles in 1992, then was daily driven and 40k electric miles were put on it between 1992-2000, after which it sat for about 15 years, then was sold to the previous owner before me who installed a 24kWh LEAF pack (re-arranged to be 3p32s), Orion 2 BMS, and TSM2500 charger in the trunk.

I had the car shipped to VT when I obtained it. When I got it, it did drive, but was in very rough shape (it is an MG with 105k miles on it at this point, after all). Over the past two months I've done the following:
  • Rebuilt rear end, including fresh rebuilt diff, and new bearings, o-rings, gaskets, etc.
  • Rewired almost everything that wasn't original car wiring. The wiring was a complete spaghetti pile when I got it; at one point I stuck my multimeter on two wires behind the dash with the car off and measured full 130V pack voltage.
  • New bushings and tie rod ends up front
  • New leaf springs in the back (even more leaves added, lol) to fix the ride height
  • New bearings in the MTC-4001 (continue reading... this is NOT done) and new pilot bearing
  • New master brake cylinder and various other brake work
  • Rebuilt clutch mechanism almost entirely. Pivot bushings for the fork were basically gone (so it was loose), pin that holds pushrod to the fork had backed out, etc. It was a mess, so I basically rebuilt the whole thing from scratch.
  • TSM DC-DC and new 12V battery
I did all of the above, and over the past couple weeks I've been driving it all over VT, mostly to bring to EV fests all over the state (almost every weekend over the summer has an EV fest somewhere). I've put around 400 miles on it since fixing a lot of stuff up.

Currently the car is still missing any sort of fuel gauge (besides the laptop connected to the Orion), and the BMS disconnect contactor (in addition to the main open-frame ignition contactor up front by the motor controller) is welded (you VERY CAREFULLY watch the laptop as you drive). I now have a proper precharge unit and a pile of EV200 contactors, so I'll be fixing this shortly as well.

Ok so now on to the major issue at the moment.

The car uses an MTC-4001 motor "customized" with a piece of L-bracket welded across the bottom to mount to the stock motor mounts. A small machine adapter is keyed onto the output shaft (this adapter also has an R8Z bearing for the pilot bearing), then the original flywheel (but with started teeth cut off and with the original mounting holes re-drilled for the motor spline adapter) bolts to this.

When I got the car, it had horrible vibrations all the time. So I pulled the motor, and noticed that the front bearing was quite loose (had worn down the motor shaft and also the case of the motor a bit), the pilot bearing was basically gone, and the clutch mechanism had disintegrated (as described above). So I bought two new bearings for my motor and a new pilot bearing, and installed them all. On the front motor bearing, I used Loctite 609 retaining compound per a (mechanical engineer) colleague's recommendation to attempt to attach the shaft to the motor. Clearly, this fix made it around 350 miles, because now the car is incredibly loud again, and pulled the motor and as expected there's lateral shaft play.

Worth also mentioning is that the small cooling fan inside the motor was cracked when I got it, and when I took apart the motor it disintegrated. Also, I was a complete idiot and forgot to pull the front c-clip when I disassembled the motor, and just pressed it out with a press, which cracked the seat for the front bearing c-clip.

I have yet to obtain another R8Z (or similar) bearing to see how worn the transmission input shaft is. However, I do expect it to be somewhat worn as when I pulled the motor for the first time, the pilot bearing was essentially gone.

Based on all this, it looks like the following is my best course of action to get this properly repaired, as the retaining compound is clearly not a good solution, particularly with the axial loads from the clutch:
  • Obtain another MTC-4001, disassemble and re-assemble into my old motor case (to avoid having to re-engineer the mounting bracket).
  • Machine a custom busing to replace my pilot bearing, that has proper fit to the slightly worn transmission input shaft. Or, perhaps it isn't that worn (since I need another bearing to check) and it will be OK with a regular-size bushing or bearing
I'm also vaguely considering upgrading to a LEAF motor and OpenInverter but that would be fairly overkill for this car (I've heard the rear ends can't handle more than about 100HP anyway) and wouldn't be "historically accurate" since this car has so much history.

Cheers, and excited to be joining this community!

- Willem
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top