DIY Electric Car Forums banner

Leaf - Gen 2 PDM/OBC/charger no output power - L1/L2 charging

7136 Views 119 Replies 4 Participants Last post by  evVanagon
I'm having a problem with L1 charging all of a sudden. This vaguely coincides with the time I put dielectric grease in the J1772 port for the winter and when the temperatures started to drop.

  • 2015 nissan leaf OBC
  • 2013 24kWh battery
  • 0 to -14C temperature outside. Battery temp is always above zero (i have the battery externally heat traced).
  • Resolve EV VCU

- When this first problem started in the fall with temperatures dropping, but with the battery well above zero, I originally plugged the EVSE in overnight and the next day it dropped 40% overnight. Indicating no charge. Then noticed with my smart outlet that there was no current draw from the vehicle. Strange. So i started investigating.

What's happening is the EVSE plugs in, I have verified the light on the EVSE says charging, I have verified the OBC is getting 100V AC inside the OBC. The OBC also registering 100V AC after the black relay before going into the underside of the OBC. So i know the OBC is getting AC voltage from the house. The EVSE does not complain with any fault lights or error messages. I have tested two different EVSEs. One stock Nissan EVSE that i've used since day 1 and my evse. Both show that they start charging but 0 Watts are being drawn from the vehicle's OBC.

  • I check LeafSpy Pro, I am seeing a 1-2A (300-600W) draw from the battery when the car wakes up by the presence of the J1772 plug being connected.
  • I have pulled apart the OBC top and bottom to check from any blown components. Nothing seems out of the ordinary.
  • The OBC is getting 100V through the EVSE properly.
  • Disconnecting the HV battery mains at the EVSE and checking the output of the OBC. I'm getting around 2-4Volts DC. This is strange.
  • I have checked the D400 (or D408?) diode and the D108 diode inside the OBC. Traced it from the control pilot circuit. They seem fine. D400 has ~11Mohms of resistance forward. And 0.542V with the multimeter's diode tester. If I jump diode D400, then the evse will stop charging and report a Diode check error. This helps me eliminate the diode as a symptom.
  • D108 also seems to be fine and reports 0.352V in the forward direction.
  • PP pin to ground is 4.74V DC
  • CP pin to ground is 11.78M Ohms forward
  • With logging EV-CAN messages. I'm seeing 0x679 register when J1772 plugged in. 0x390 - OBC_AC_status voltage is 100V, 0x390 - OBC_Charge_Power report 0kW. I'm seeing 0x390 and OBC_Charge_Status=charging or interrupted. Ox1DB seeing LB_Current with -0.5 to -1A.
  • 12V battery is charged and tested to be good.

Other things I noticed while in there:
Also, in this investigating R8000 and R80008 seem to be shorted. And with a magnifying glass I was able to see "0" printed on the top which makes me beleive these two resistors are just "jumper" resistors in the form of a SMD component.
See less See more
1 - 20 of 120 Posts
Is it a nissan laef OBC, or what is it?

where are you located that used 100vac for the mains?
Yes, a 2015 nissan leaf OBC.

An old old house. This has always been a problem around here. Right now that circuit is 101.8VAC.
Dielectric grease is non-conductive and is used to block galvanic corrosion currents. It's also used in non-moving connections...the cold weather likely made it nastier than it already is.

Suggest you either clean up every bit of residue from it or replace the connector.

Try not to get yourself killed around that connector, because you are distracted by the problem(s). Always assume a contactor/relay fault.
Just cleaned the connectors out with isopropyl alcohol and aerosol contact cleaner. Was full of dielectric grease. Let it dry and attempted again with no difference. OpenEVSE says 0.0 watts being drawn. I've made sure all 5 pins (Line, Neutral, GND, Proximity and Control Pilot) have good continuity back into the OBC.

Of course always staying safe. Always making sure mains are disconnected and no voltage present.
Here's a can dump log of the car charging but 0W output power. Charging starts at normalized timestamp 182477198 when the id=0x679 message is written. Anyone have a can log of a successful charge with charging power > 0W?

I've been using SavvyCAN and these .dbc files: GitHub - dalathegreat/leaf_can_bus_messages: LEAF CAN bus message decoding with proper database files


From what i've gathered as important. There probably is a bunch of stuff im overlooking and i'm not sure if this is a hardware problem in the OBC (onboard charger) that is making it not possible to supply any current as shown in the (OBC_Maximum_Charge_Power_Out=0kW) OR a signalling problem in the LBC (lithium battery charger) where the LBC isn't asking for any charging power from the OBC. The latter doesn't seem to be the case because LB_Max_Power_For_Charger slowly rises to 22.7kW and the OBC_charge_power and OBC_maximum_charge_power_out still remains at 0kW

SOC is ~10%
182477198 - 0x679 - J1772 plug inserted
182527365 - 0x390 - OBC_Status_AC_Voltage = No signal & OBC_Charge_Power = 0kW & OBC_Maximum_Charge_Power_out = 6kW & OBC_Charge_Status = 0
182627499 - 0x390 - OBC_Status_AC_Voltage = No signal & OBC_Charge_Power = 0kW & OBC_Maximum_Charge_Power_out = 6kW & OBC_Charge_Status = Finished
182727599 - 0x390 - OBC_Status_AC_Voltage = No signal & OBC_Charge_Power = 0kW & OBC_Maximum_Charge_Power_out = 0kW & OBC_Charge_Status = Charging or interrupted

182863873 - 0x1DB - Total voltage=511.5V & LB_Current=511.5A & LB_inter_lock=Not interlock connected & LB_MainRelayOn_flag = No-permission
182864133 - 0x1DC - LB_Max_Power_For_Charger = 92.3kW
182873885 - 0x1DB - Total voltage = 511.5V & LB_Current = -1.5A
182884122 - 0x1DC - LB_Max_Power_For_Charger = 0kW
183123940 - 0x1DB - Total voltage still = 511.5A & LB_current = -1A & LB_Inter_lock = interlock connected
183474016 - 0x1DB - Total voltage drops to 350V & LB_Current is still -1.5A

183534267 - 0x1DC - LB_Max_Power_For_Charger = 0.1kW
183584043 - 0x1DC - LB_Max_Power_For_Charger = 0.2kW
183974358 - 0x1DC - LB_Max_Power_For_Charger = 1.0kW
184529969 - 0x390 - OBC_Status_AC_Voltage = 100V & OBC_Charge_Power = 0kW & OBC_Maximum_Charge_Power_out = 0kW & OBC_Charge_Status = Charging or interrupted
185154952 - 0x1DC - LB_Max_Power_For_Charger = 3.3kW
185154734 - 0x1DB - Total voltage drops to 350V & LB_Current = -1.0A
0x1DC - LB_Max_Power_For_Charger slowly rises to 22.7kW
See less See more
What could be intemittent with the interlock? Dielectric grease get into any HV connector contacts?
No grease in the HV connectors. Just the J1772 port. It seems like it's only registered as not connected right after the J1772 plug is inserted and reverts. Not intermittent after that.

Can you wire up to use 240vac (Level 2)? Maybe the 100 vac level 1 is too low for the OBC to turn On.
I can try that. With 10% SOC left not really possible to move, but with the OpenEVSE I can run a extension line from the stove. I was seeing 106VAC last night and no difference.
Are you sure a ground fault is not being detectedby the EVSE? You did say, "old house"...most of which have no ground at all. That will stop charging in its tracks. As will a broken or non-existent ground in the receptacle/cord you are using.
No this is not a problem. The outlet i'm using is 3-wire and grounded. I have been charging from the same outlet since September without issue. I have seen a ground fault with a different outlet and the Nissan EVSE would just blink ready or constantly click. In this case now, the ready light is solid, plug in the connector, relays click, charge light comes on steady and stays on as if the car is charging. Same with the OpenEVSE which has a display that shows 0.0A and 0kWh.
Update: I have check again with charging on a L2 charger.

- Input 243VAC, and the OBC is outputting 5.42VDC. No OBD codes thrown. Stumped. Triple checked diodes again.

Circuit component Passive circuit component Hardware programmer Computer hardware Electronic instrument
Purple Font Art Urban design Graffiti
Circuit component Passive circuit component Hardware programmer Font Electronic engineering
Circuit component Passive circuit component Blue Hardware programmer Electronic component
See less See more
i think there is a thread about the details of the Gen 2 OBC.
Im having a hard time finding this thread.

Check that 30A fuse near the pack, plus check all the fuses you can see.
Which exact fuse are you referring to? The one near the pack HV PDM wires. I've checked all visible fuses on top of the charger and all have continuity. Meaning all the ones visible in the posted pictures above. The 30A fuse I think you're referring to is the one in the top-left of the picture. In the belly of the charger I found no fuses.

With the power OFF you would measure about 10 Ohms from the AC input Neutral over to the blue bubble, this is thru the precharge pair of ceramic resistors, one of which may have an internal fuse.
With power off, I just measured this to be ~7.43-8.43 MegaOhms. This seems like a problem. Going to find the source of this resistance and I'll report back. What components are support to be 10 Ohms. Where did you get this from? If it has a fuse ill try and isolate it.
I think I found this ceramic resistor. Shindengen - Part# 50JCB 80 - B0142
Resistances I have between these pins. Pin 1 to the left.

Pin 1-2 = 3.39MOhms
Pin 1-3 = 3.39MOhms
Pin 1-4 = 8.17MOhms
Pin 2-4 - ~5MOhms
Pin 2-3 = 49.7kOhms
Pin 3-4 - 3.39MOhms
Across the white ceramic thermal fuse resistors I'm getting 8.4Ohms and 8.7Ohms on the other. Circled in pink. Numbers: 10K TAM 8.2OhmsJ 134

Circuit component Passive circuit component Hardware programmer Computer hardware Urban design
See less See more
You would need to use the diode check function on your meter to test a diode, see the pinout in the photo.
Yup the bridge rectifier checks out with forward biased voltage across each diode as 0.450V and successfully blocks in reverse. No issues here and not diving any further into this precharge circuitry.

I'm currently trying to cross reference @muxs successfull L1/L2 CAN bus charging log he posted in this thread on page 3: Stand alone OBC/PDModule EV system Can 2015 - SOLVED - Page 3 - My Nissan Leaf Forum
Some highlights between the EV Can log I posted above and mux's from the pastebin off page 3.

0x1DA = MG_InputVoltage is 344 but 0x1DB - LB_Total_Voltage is 344.5 whereas mux's MG_InputVoltage is 380V and 0x1DB - LB_Total_Voltage is 378V

Another glaring difference:
0x1DB - LB_MainRelayOn_flag is always "No-permission" in my logs and in mux's it is "Main Relay On Permission". This is interesting because I can put the engine in D and get power to the wheels.

0x1DB - LB_Current is equal to -1A for me and mux's shows +2A

0x5BC - LB_output_power_limit_reason is "Capacity Drop" in my log and "Normal" in mux's

Some of the similarities:
0x1D4 - Relay_Plus_Output_Status for both of us is "Main Replay Plus ON" and
0x1D4 - StatusOfHighVoltagePowerSupply for both of us is "High Voltage Supplied"
0x1D4 - ChargeStatus is both "Charging"
0x1F2 - CommandedChargePower for both of us is always 100
0x1F2 - TargetCharge_SOC is 100%
0x1F2 - Charge_StatusTransitionRequest is "Normal Charge"
0x1DB - LB_Inter_lock is "Inter lock connected"
0x1DC - LB_Charge_Power_Limit is ~22kW for both
0x1DC - LB_Max_Power_For_Charger is 21.7kW for mine and 17.7kW in mux's. Mine ramps up from 0kW to 21.8kW
0x1DB - LB_Full_charge_Flag is both "0"
0x1DB - LB_Failsafe_Status is both "Normal Start Request"
0x1DB - LB_relay_Cut_Request is "No-request"
See less See more
Attached the 240VAC L2 charge sequence. There is 4 charge sessions logged in this file as denoted by the 0x679 messages. The first session had the OBC cover off probably setting an interlock flag somewhere.

Regardless: I'm still seeing
0x1DB - LB_Current is equal to -0.5A to -2A
0x5BC - LB_output_power_limit_reason is "Capacity Drop"
0x1DB - LB_MainRelayOn_flag is always "No-permission" in my logs and in mux's it is "Main Relay On Permission". This is interesting because I can put the engine in D and get power to the wheels.
0x1DC - LB_Max_Power_for_charger - slowly climbs from 0kW to 25kW


That is not good, should not be able to drive while charging.
No, not while charging. I'm just saying that obviously the main-relay does get Permission at some point since I can put the car in Drive and can rev the engine but not while the charging cable is attached. But for some reason while the car is IGN off, parked and charging, the main-relay is set to "No-Permission". That's odd to me.
Attached is a Drive can log. With transmission in neutral (so very little torque). Conclusion, is that i'm still seeing:
0x1DB - LB_MainRelayOn_flag = "No-permission" even though there is HV battery making it through the inverter and into the engine.

Thanks for the video reference. I've seen this one long ago. Was the first video that helped me dive into the PDM and look for anything fried and burnt up. Haven't found anything yet.


Maybe it's the little white relay on the Lithium Battery Controller (LBC); x01DB is carried in the HVBAT section of the dbc, where dala's notes indicate that is the LBC. That relay is used for checking the insulation resistance.
This is interesting. And could be leading to my QC issues as well. I'm assuming there that the HVBAT only checks insulation on a charge? Why would it start charging but not give any DTCs if this insulation check fails though?

Can you run laefsypy to read the DTCs?
Yes i have Leafspy since the beginning. No DTCs thrown during charging except a generic U100A CAN which has always been thrown since upgrading to v2.0.0.0 of Leafspy that Turbo released.

What was the story with the 511 VDC pack voltage? And now it's reading ~5V
511VDC is what's being read by the ECUs at the start of a charge then it eventually comes back down to Pack Voltage of ~344VDC.

5VDC is what is outputted from the OBC without the HV Pack voltage connected. If you see the picture above I have a 4-bolt plate disconnected that normally connects the output of the OBC to the big copper bus bars connected to the HVBAT input. Earlier versions or just 3.3kW versions of the OBCs (The one Johu dissects) there is a choke ontop of this plate. I temporarily disconnect this plate before charging to see if I could read OBC output voltage without the HV bat input connected. When connecting this plate and therefore connecting the output of the OBC ouput to the input of the HVBAT, I get Pack_Voltage during charging and no power transfer happenning.
Circuit component Green Passive circuit component Hardware programmer Electronic instrument

The VCM or OBC checks that AC is available on the input side and measures the pack voltage on the Output side, before it will turn ON charging. It sounds like a fuse on the output side is open such that it can't read the pack, or a main contactor is open, etc. Something is not making sense to have 5.42VDC output on OBC.
Yes this makes sense when the connecting plate is off. On Gen 1 OBCs there is a choke ontop of this plate.

Do you have another EVSE that you could try to rule out basic issues?
Yes. I have the factory EVSE and an OpenEVSE. Both say the unit is charging but the OBC has no output power.
See less See more
Also what's weird is the +1 to 2A (300 to 800W) HV battery draw when charging or just IGN On. These kind of watts makes me beleive it's the HV battery heater but it's only +2C inside the battery. Is this a cuase for concern? I've seen this 300 to 800W draw even when it's upwards of +6C inside HV battery.

Manual states the heater shouldn't be turning on until under -20C. Maybe this draw isn't the HV battery? Anything else it could be?
--or maybe the LB heater relay is erroneously stuck on, and causing the charging to not commence until it turns off. But with a stuck heater relay it won't ever stop the battery heater.

Font Parallel Motor vehicle Art Screenshot

Product Rectangle Font Line Slope
See less See more
But there was an error previously when the control board was reading 511V.

i've never tried running a charger unloaded but i'm sure it will set fault codes in the OBC, maybe temporary or permanent.

Has anyone else ever tried to run a charger when not connected?
Every time I plug in the J1772, and after CAN message 0x679, the voltage is read as MG_InputVoltage (Inverter) 510V then reduces back down to the HV batt Voltage of ~344V. As shown in these images. Also the MG_OutputRevolution is obviously wrong at +16383rpm. With this, I would not take the +510VDC seriously.

Font Parallel Rectangle Slope Number

Font Computer Parallel Personal computer Technology

Colorfulness Slope Font Rectangle Screenshot
See less See more
Yeah, we have extreme cold days but I have the pack lined with a 300W heat traced cable underneath the HV battery and the van's interior is heated during the day when working in there. The HV battery temp sensors are registering +3C as per the Leaf Spy Pro screenshots in the second last post. The HV battery pack is inside the van and not exposed to outdoor temps. It's not that cold right now (not below -20C), and the motor temp you can see is -8C which is exposed to outdoor air.
1 - 20 of 120 Posts