DIY Electric Car Forums banner

Need help with Ford-Azure Transit Connect battery diagnosis

9531 Views 96 Replies 11 Participants Last post by  Ron_84
Hi i have a Transit Connect electric and one half of the batterypack wont connect/engage does anyone know soething about this cars anymore? i am suspecting the BMS but no fault code or anything is showing, ESS1 stays in "contactor state" as first picture shows for a while then it disconnects, ESS2 shows "xxxxC400" for just a second then it changes to xxxxC600 and contactor voltage shows up and the car is running on one half..

Thanks Robin
Computer Personal computer Azure Gadget Font
Computer Personal computer Azure Font Electronic device

ect,
61 - 80 of 97 Posts

· Registered
Joined
·
5 Posts
Hi Ron. I currently have our 2011 Azure transit at the mechanic. I'm working with a head tech from Azure. He said the battery voltage sensor on pack B is bad. We haven't dropped the pack yet. Any idea what the voltage sensor is? Thanks for any help!
 

· Registered
Joined
·
101 Posts
Hi all
To all owners of Ford Azure Dynamics:
these days were lucky for me: I fixed the car. Let me remind you: the turtle lit up, the mileage decreased by half. The TCBEV program showed, that one half of the battery was turned off because one of the BMS board stopped sending temperature and voltage. Flashing the battery did not help, we could not fix the board, so we began to look for a replacement board. Replacing the board, the battery turned on.
Important: the spare board must be from the same place as the damaged one ( for example, if we have no voltage from cells 0..11 and temp. sensor 0 showing -40, we need the board, which was working on the same 0..11 cells).
This is my specific case, yours may be different, but please consider.

Azure Wood World Rectangle Font

Good luck to everyone, I am here (y)
 

· Registered
2011 Ford Transit Connect Electric
Joined
·
13 Posts
To all owners of Ford Azure Dynamics:
Hello I have a person who is an expert of these rechargeable modules. What he wants me to do is get raid of all these modules and install a new module and change all bad cells. I am still thinking what to do as my one charge only up to 30%. He name is Vjay and located at 445 Midwest Rd, Toronto, Ontario. Since you all have a better idea, what do you recommend?
 

· Registered
Azure Dynamics (Ford) Transit Connect 2012
Joined
·
36 Posts
Discussion Starter · #66 ·
To all owners of Ford Azure Dynamics:
Hello I have a person who is an expert of these rechargeable modules. What he wants me to do is get raid of all these modules and install a new module and change all bad cells. I am still thinking what to do as my one charge only up to 30%. He name is Vjay and located at 445 Midwest Rd, Toronto, Ontario. Since you all have a better idea, what do you recommend?
Is the yellow wrench and turtle lit up? have you read the fault codes in the battery? there is so many things in the battery that can cause this problem, software failure, water leaking inside battery, bad cell, bad master bms (2 of them) or a bad slave bms (16 of them) or bad contactor, precharge resistor or maybe a temp sensor..... but all of them are repairable and i wouldent go that way to get rid of all in the battery before everything else is checked..
 

· Registered
2011 Ford Transit Connect Electric
Joined
·
13 Posts
Is the yellow wrench and turtle lit up? have you read the fault codes in the battery? there is so many things in the battery that can cause this problem, software failure, water leaking inside battery, bad cell, bad master bms (2 of them) or a bad slave bms (16 of them) or bad contactor, precharge resistor or maybe a temp sensor..... but all of them are repairable and i wouldent go that way to get rid of all in the battery before everything else is checked..
Is the yellow wrench and turtle lit up? have you read the fault codes in the battery? there is so many things in the battery that can cause this problem, software failure, water leaking inside battery, bad cell, bad master bms (2 of them) or a bad slave bms (16 of them) or bad contactor, precharge resistor or maybe a temp sensor..... but all of them are repairable and i wouldent go that way to get rid of all in the battery before everything else is checked..
Thank you sooooo much for your reply. I checked with the scanner and the scanner tells me in battery pack 0 to 5 cells are not reading. like you said it could be either Slave BMS or the battery. I ordered 10 batteries for Ali express and waiting for the delivery. Since those were shipped by sea cargo it will take time. Proverbially I might get those by end of November.
 

· Registered
Joined
·
101 Posts
Thank you sooooo much for your reply. I checked with the scanner and the scanner tells me in battery pack 0 to 5 cells are not reading. like you said it could be either Slave BMS or the battery. I ordered 10 batteries for Ali express and waiting for the delivery. Since those were shipped by sea cargo it will take time. Proverbially I might get those by end of November.
Hi
If it's not a secret, what was the cost.
I need full 96 cells.:cry:
 

· Registered
2011 Ford Transit Connect Electric
Joined
·
13 Posts

· Registered
2011 Ford Transit Connect Electric
Joined
·
13 Posts
61 - 80 of 97 Posts
Top