DIY Electric Car Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hi all,
I've been looking to hire someone to help me for a while now but still haven't found someone who is experienced enough to troubleshoot the issue. I have a 1962 MG Midget conversion(Curtis 1221B controller/presotlite series wound dc motor/kepco dc dc converter) - (12 years ago) that ran great until 2 years ago when it had a fender bender. After fixing the body and getting the brakes working again and a new battery pack (8 12v deep cycle batteries) my trusty K&W charger died... but I now believe it is a short somewhere that possibly caused the charger to die (I have since replaced it with a delta q charger)... when i drive the car for 5 minutes it suddenly loses power and waiting 3 minutes allows it to start again for another few minutes until it loses power again... also if i charge the batteries individually with a 12v 3 stage charger they all charge up fine but the new Delta Quic 96v charger faults after a few minutes...

so 2 issues that may be caused by same problem... any and all suggestions and ideas most appreciated!!
Thanks!
Mary
 

·
Registered
Joined
·
1,476 Posts
i'll throw an idea in the pot--there is a ground fault somewhere in the system, likely due to the accident.

It could be that somewhere in the pack or brush residue in the motor has created a path to chassis ground

The deltaQ charger is probably making a ground-fault check before it will turn on charging. So the chassis may need a path for this earth-ground check. It is hard to know or guess without a schematic and more information.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
Thanks! Yes a schematic would really help ... wish i had one ;) but that is the second suggestion on a ground fault so that is where i'm going to start! now i need a plan on where to start! :)
THX!
Mary
 
1 - 3 of 3 Posts
Top