DIY Electric Car Forums banner

Supplemental : Tesla 10Kw Open Source Charger Controller

3313 Views 17 Replies 5 Participants Last post by  Tomdb
Here is a supplemental thread for the "Tesla 10kW Open Source Charge Controller" thread, since the prior one is (as yet) inaccessible.
1 - 6 of 18 Posts
I've been using the software written by Damien, Colin Kidder, and mostly Tom Debree. I took a copy of the software so that I could configure it to work with the control scheme in the TesLorean (i.e. all stop/start charging commands come over CAN).

My setup
- EVSE (240v 40A)
- Battery currently at ~365v
- Attempting to charge to 400v
- Singlephase
- currReq (current request) limited to 10A

I've tested with the modified version and the version from Tom's github, but I'm getting the same set of symptoms when attempting to charge...

1) DC total Cur:0.09 and stays at a very low value?
2) AC current reports as 0 for modules 0 and 1, and 0.53 for module 2
3) The charger appears (clicking relays and lights) to start, but after 2-3 seconds the modules click off, the EVSE relays click, and then the modules switch on again. If feels like the modules are resetting after a few seconds but it is hard to tell.

A couple of questions...
EN ? - Is this 'Enabled' (as in the module is enabled?)
Flt ? - Is this a Fault flag?
Stat ? - Status, any idea as to the meaning ?


PS. Attachment "July 8th 338pm Stock.txt" is the serial debug log from the software from Tom Debrees' github. The other attachment "July 8th 250pm noAuto.txt" is a run with the software I modified (autoenable is switched off in this run).


See less See more
Did you start it with auto start?

Can you try running it in 'X1' which is Can Master mode. Please send me a full serial log from the start.

Is there any version of software where it does work?
Hi Tom,

I had been testing it with autostart enabled, but for the logs uploaded yesterday (July 8th) it was not enabled. With autostart enabled, it enabled the modules as expected when the plug was clicked in. Otherwise all the symptoms and run reports were the same (resetting after 5-7 seconds, FLT flag 1).

I did a run in CAN Master mode (both with the EEPROM parameter, and also entered X1). Same symptoms as before.

I looked back over old logs where I was testing 110v, type 1, singlephase. To look at them now, they were also reporting FLT 1 when charger was ON.

In the ZIP file is a capture of the lastest software from your GitHub and also a log from my modified version of it.


There's a good chance I exposed the charger to an "Un-pre-charged" connection to the battery. My software controlling the Chevy Spark A123 battery pack probably wasn't enabling the pre-charger circuit correctly before. Hopefully I didn't kill anything :(


See less See more
Dr Jeff : Please check newest code on github.

Did some tweaking purely on the single phase side.

If you run the code please capture the canbus to check what is being broadcast.
Hi Tom,

I downloaded the new code and updated the settings for my setup (see file in the ZIP for settings...). I also captured the internal CAN traffic with SavvyCAN, and I captured the Serial port output messages. I started and stopped the charging with the 's' command.

Something interesting happens about 2.5 seconds into the charge ('s' command) where the 'AC cur', but then it drops after another few seconds.

The charger did the same 'reset after 5-7 seconds' several times (maybe 3 times) during the test.



Can you please test it pretending it is a 'three phase' and set it like that.
then command the current limit to 4 or 5 amps to test.

I want to diagnose what is going wrong that way.
I ran the test with the setting at Threephase. After I ran the test and shut everything down I remembered I left currReq at 15000 (10A). Hopefully that won't mess it up too much.

I also thought about changing it to Type 2 (to correspond with the ThreePhase), but I was concerned about how different the Type 2 settings are in the code (EVSE current detection) so I left it as Type 1.

Thanks for taking a look


Is this forum dead now? Seems all my Tesla related stuff is gone.
Hi Damien,

Serious forum issues when they (the company providing the service) transitioned to a new platform. Hopefully the pages have just become 'un-linked' and can be reconstituted soon. From my postings, everything in about the last year is inaccessible.

1 - 6 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.