DIY Electric Car Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
311 Posts
Discussion Starter #1
I ordered a 6.6 kW charger from TC and I requested both CAN control and Enable - I wanted a failsafe off in addition to the control offered by CAN. The idea is to pair it with the ZEVA BMS and program the charger to work on either a standard 10 A socket or a 32 A socket, by changing the charge current.

Upon installing it I realised I;d been sent the Enable only version. Turns out you can have either CAN control or Enable, not both.

As we have only installed 6 of the 8 battery modules, the battery now has a Vmax of 300 V, while the charger is currently set to a Vmax of 400 V. It had been charging happily up until the first cell hits 4.2 V and then it gets shut down by the bMS.

However it recently stopped working. It shows all the usual signs of functionality, but gives an error when the enable line is connected. At no point does it push any more than half an amp into the battery before stopping and giving a green-green-green flash code.

I tried one of my air-cooled TC chargers I use for Voltron - it's set to a Vmax of 350 V or 84 cells in series. Considering the Prelude only has 72 cells in series, I figured it can't be too far off the mark.

Alas, it too fails to charge. It tries, makes some quiet static ticking noises, then stops. However, back on the race bike, it charges just fine.

So I was wondering if anyone has experience with these chargers, and whether or not the fixed voltage chargers with Enable control are fussy about their operating range. Seems I need to fit the last two battery modules as soon as I can, otherwise I might have the same problem in a few weeks time when the CAN controlled charger arrives.

:confused:
 

·
Registered
Joined
·
311 Posts
Discussion Starter #2
The charger works now!
I wanted to move the car, so I got in, powered up, pressed the throttle and it dropped out. Repeat, same thing...

Aha! The master contactor isn't closing! The master precharge relay was closing, but it was trying to pass big voltages across a 200 R resistor inside the pack. No go.

Why was the master contactor not closing? The precharge delay timer I bought off Alibaba stopped working. Good thing I put it up the front so I can access it. Since nothing capacitive is being powered from the battery at this stage (A/C compressor will be a while off) I just omitted the precharge delay and turned both on at the same time. And it charges, drives, and works as it should!
 
1 - 2 of 2 Posts
Top